Difference between revisions of "Testing Glimpse"

From GlimpseWiki
Jump to navigation Jump to search
(Explicitly disable GPG verification https://github.com/glimpse-editor/Glimpse/issues/175#issuecomment-539405849)
(→‎Flatpak: Explicitly ask to install the GNOME platform https://github.com/flatpak/flatpak/issues/2116#issuecomment-539517406)
Line 8: Line 8:
 
=== Flatpak ===
 
=== Flatpak ===
   
If you haven't done so already, you first need to [https://flatpak.org/setup/ install Flatpak and enable Flathub on your machine]. Glimpse depends on the GNOME platform runtime which is distributed by Flathub.
+
If you haven't done so already, you first need to [https://flatpak.org/setup/ install Flatpak and enable Flathub on your machine]. Glimpse depends on the GNOME platform runtime which is distributed by Flathub:
  +
  +
<pre>
  +
$ flatpak install flathub org.gnome.Platform//3.32
  +
</pre>
   
 
We provide our own Flatpak repository with builds from our development branch. To enable it, just run the following command in a terminal:
 
We provide our own Flatpak repository with builds from our development branch. To enable it, just run the following command in a terminal:

Revision as of 13:37, 8 October 2019

All test builds for Glimpse are hosted on https://build.glimpse-editor.org

Windows

TODO

Linux

Flatpak

If you haven't done so already, you first need to install Flatpak and enable Flathub on your machine. Glimpse depends on the GNOME platform runtime which is distributed by Flathub:

$ flatpak install flathub org.gnome.Platform//3.32

We provide our own Flatpak repository with builds from our development branch. To enable it, just run the following command in a terminal:

$ flatpak remote-add --if-not-exists --user --no-gpg-verify glimpse_devel https://build.glimpse-editor.org/dev/flatpak/glimpse-devel.flatpakrepo

Next, either find Glimpse development builds in your software center, or install it in a terminal:

$ flatpak install glimpse_devel org.glimpse_editor.Glimpse